AWO Coupon error is Hikashop


  • Default avatar
    mikekiy    
     7 months ago
    0

    Seyi

    I am using AWO Coupon (latest) with Hikashop (3.0.1).

    The coupon functionality is all good.  The issue comes when moving to payment where I receive the following error message - see attached pic.

    The coupon is still correctly calculated but obviously I would rather my customers didn't get a confusing message..

    Have you any ideas for this?

    Kind ergards

    Mike
    8Endp5R.jpg

  • Your avatar
    seyi    
     7 months ago
    0

    Hello,

    So using AwoCoupon latest, 2.5.6.  How is the coupon setup?  Also how is your checkout setup in admin->hikashop->configuration->checkout tab, first section?
  • Default avatar
    mikekiy    
     7 months ago
    0

    Seyi

    Thanks for coming back to me.

    AWOCoupon v. 2.5.6

    The Coupons are set up as one Parent containing 8 Children - all calcualate correctly.

    Here is a screenshot of the Checkout Workflow.



    Kind regards

    Mike

  • Your avatar
    seyi    
     7 months ago
    0

    Hello,

    I have tried duplicating this issue locally but cannot seem to.  Is it possible to send temp admin and ftp access via private message to debug directly?

  • Default avatar
    mikekiy    
     7 months ago
    0

    Seyi

    Thanks - I have sent you a PM

    Cheers

    Mike
  • Your avatar
    seyi    
     7 months ago
    0

    Hello,

    Thanks for the access.  I believe the issue is now fixed.  I had to alter code in www/administrator/components/com_awocoupon/helpers/estore/

    So if you need to copy it to another site, please copy that folder.  This issue will be fixed in the next update.