AWO coupon error 20 JPath::check Snooping out of bounds @ JPATH_COMPONENT/views


  • Default avatar
    dennis9    
     2 years ago
    0

    Hi,

    I'm developping a webshop, using Joomla / Virtuemart and have AWO Coupon Pro installed.
    When I adding a coupon code, sometimes I get the following error;

    =======
    20
    Fout: 20
    JPath::check Snooping out of bounds @ JPATH_COMPONENT/views
    =======

    After refresh the page, the coupon code works well....

    What can be the problem and wat can I do to solve it?
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    I dont think this is a problem with coupons. did a quick search on google and found this post for example:
    http://forum.joomla.org/viewtopic.php?p=2478578

    Seems to be some type of a cookie problem. Try it in another browser to see if you get the same results.
  • Default avatar
    dennis9    
     2 years ago
    0

    I tried an other browser, and the same error appears.

    I have found a specific situation where it goes wrong.

    I have an coupon code with discount on specific products, when I add the code without adding the specific product to the cart, there will be an error displayd that the code isn't right. Afther that I add the specific product and add the code again, then the error 20 appears.

    After refreshing the page, it goes well again.


    I also use bonus products, but the error is shown also without trigger a bonus product.
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    I could not produce it. Can you send a pm with how to test this on your site, including the coupon code?
  • Your avatar
    seyi    
     2 years ago
    0

    Hello,

    Your hunch on bonus was correct. There is an incompatibility issue between AwoCoupon and Bonus. If you disable either, it should work fine. Please try this fix:

    in www/administrator/components/com_awocoupon/helpers/estore/virtuemart/couponhandler.php around line 305 is this:

    $frontcontroller = new AwoCouponSiteController();

    Please change it to this:

    $frontcontroller = new AwoCouponSiteController( array('base_path'=>JPATH_ROOT.'/components/com_awocoupon') );

    I believe that will fix the problems.
  • Default avatar
    dennis9    
     2 years ago
    0

    this works like a charm, thank you very much!