After upgrade, MySQL Error in History - Can't save configuration file -Coupons do not work


  • Your avatar
    seyi    
     5 years ago
    0

    Hi,

    After upgrading to v1.4, we seem to be having issues with the installation.

    We cannot save settings in the configuration file

    We get the following error in the History of Uses tab:
    Warning: mysqli_num_rows() expects parameter 1 to be mysqli_result, boolean given in /home/worldfoo/public_html/libraries/joomla/database/database/mysqli.php on line 360

    In the front end, we are unable to use valid coupons.
  • Your avatar
    seyi    
     5 years ago
    0

    The configuration is a known issue for some installations and can be fixed by updating the code:

    in www/administrator/components/com_awocoupon/helpers/awo_params.php, on line 29,
    change
    <?php
        $value 
    = empty($value) ? 'NULL' '"'.mysql_real_escape_string($value).'"';
        
    $db  = & JFactory::getDBO();
    ?>


    to
    <?php
        $db  
    = & JFactory::getDBO();
        
    $value = empty($value) ? 'NULL' '"'.$db->getEscaped($value).'"';
    ?>


    This will be fixed after version 1.4.0.


    For the other error, can you turn on debug mode in global configuration and refresh the page to see what the error is? I have a feeling you are going to receive the error in this post:
    http://awodev.com/forum/awocoupon/help-section/adminitration-error-history-uses-coupons#comment-1698